191 Aufrufe
Mein Server macht zu ganz merkwürdigen Zeiten spontan Backups, ohne mir ersichtlichen Grund. Ist so nicht eingestellt: er soll 13:30 und dann 6h später machen ...

Stattdessn um halb neun oder um 10 während der Sprechstunde ... zusätzlich ...

Hat das was zu bedeuten?
Gefragt von (10.3k Punkte) | 191 Aufrufe
0 Punkte
Geht bei uns genauso merkwürdig ab, habe nächsten Mittwoch ein date mit tomedo um das zu ergründen.......

3 Antworten

Scheinbar macht der Server ein neues Backup sobald man sich am Server anmeldet (HighSierra) ...

Liebe Zollsoftler: Was meinen Sie dazu?
Beantwortet von (10.3k Punkte)
0 Punkte

Zollsoft ignoriert sowas...

Das ist schon seit Sierra so. Kommt nur vor wenn man sich per "Bildschirmverwaltung" auf den Server verbindet. Sobald man die Remote-Session schließt, ist die Berechtigung für den Backup-Prozess für den Server weg. Der Server macht dann übrigens auch tagelang kein Backup.... erst wenn man sich wieder verbindet wird dann sofort das ausstehende Backup angeschmissen...

...mehr als Achselzucken war bisher nicht aus dem Support herauszukitzeln...

die Antwort auf dem tomedo-day 2017 war: wir verändern jetzt nichts mehr an den Servertools, da die ohnehin komplett überarbeitet werden für den kommenden Linux-Server...

Passiert bei mir wenn ich mich lokal am Server anmelde ...

Wenn der Server lokal weiter läuft ohne sich auszuloggen (Also alle Sicherheitseinstellungen ausmachen wenn z.B. der Bildschirmschoner kommt)... dann klappts mit dem Backup. Ist nicht nur Datenschutzrechtlich ein Witz...

Siehe Diskussion vom Septemer 2017 hier:

https://forum.tomedo.de/index.php/11411/macos-high-sierra-os-10-13?show=12685#c12685

 

Interessant, beschreibt das Verhalten aber nicht.

Die geplanten Backups erfolgen ja laut Logeintrag im Serverfenster korrekt, nur eben zusätzlich sobald man sich am Server anmeldet ....

Also bei mir findet dann kein Backup statt. Dafür stürzen die Servertools regelmäßig ab... Ich schicke zur Zeit jede Woche ein Log an den Support... :P

Wenn der Server zusätzlich ein Backup macht ist es doch nicht schlimm :) - Hauptsache die automatischen Backups laufen...
Ja, so richtig schlimm ist das nicht, deswegen quengel ich ja auch nicht so doll. Aber es funktioniert eben eigentlich nicht so, wie es soll. Ich denke, es ist für die Entwickler zumindest eine -evtl. hilfreiche- Information.
Habe seit einigen Wochen (konkret: seit unser Server auf High Sierra läuft) nur noch sporadisch Auto-Backups; meist startet das Backup erst, wenn man sich per Bildschirmanzeige mit dem Server verbindet. Dachte nach ausgiebigem Kontakt mit dem Support und Auslesen der Server-Logs ("vielleicht liegt es ja an CCC, den Sie zusätzlich nutzen") ja an ein individuelles Problem, scheint offenbar aber kein Einzelschicksal zu sein. Nebenbei: CCC führt seine Sicherungen/Clones nach wie vor zuverlässig aus!

Ich finde es ist keine zumutbare Lösung, bei den DB-Backups jedes Mal selber tätig zu werden damit es klappt!

An Zollsoft: bitte schnelle Überarbeitung der Server-Tools, danke!
CCC benutze ich auch. Aber wie schon geschrieben: die normalen Backups laufen bei mir, erst seit High Sierra aufgefallen, CCC v5.xxx (aktuell) läuft problemlos.
Ich könnte mir vorstellen, dass das eventuell mit dem Ruhezustand/Energiesparoptinen des Servers zusammenhängt. Vielleicht ist ein Backup nicht möglich, wenn der Server in den 'Winterschlaf'/hibernation verfällt und das backup wird erst wieder aktiv, wenn man sich aktiv auf den Rechner einloggt.

Können sie einmal testen was passiert, wenn Sie das hibernate des Servers verhindern? Am einfachsten geht das über das Terminal. Dort den Befehl 'caffeinate' oder 'caffeinate -t 360000' (zeitlich begrenzt für 100 Stunden) absetzen. (Mit Koffein kein Winterschlaf).
Beantwortet von (31.7k Punkte)
0 Punkte
das betrifft jetzt aber nur den Kollgen Mantzel, oder?
Kommt drauf an, ob bei Ihnen auch jemand regelmäßig per Bildschirmfreigabe auf den Server schaut, und die Backupzeiten mit diesen Zugriffen korrellieren.
eigentlich schaue ich immer direkt, lokal auf den Server. Die Backups passieren nicht jedes Mal... sehr inkonsistent... heute am späten Vormittag zB nicht ...
Auf dem Server sind natürlich alle Energiesparoptionen abgeschaltet.

Man kann das Verhalten auch direkt nachstellen. Wenn man sich mitten im Backup aus der Remote-Session ausloggt bricht das Backup ab....d.h. das Backup läuft mit dem lokalen User und nicht als "Daemon"....
Das Backup bricht auch ab wenn der User gelocked wird... also der Bildschirmschoner so lange läuft bis das User-Prompt kommt.

Riecht ein bisschen nach fehlenden Laufrechten des Backup-Threads...
Moin, Moin Herr Berg,

an Koffein-Mangel beim Server lag es wohl nicht: weder mit noch ohne Zeitbegrenzung führt caffeinate dazu, dass die Autobackups sauber durchlaufen, erst bei Verbindung über Bildschirmanzeige wird das Bauckup angestoßen bzw. abgeschlossen.
wirklich eigentümlich. Bei mir läuft alles wieder wie es soll, ohne dass ich etwas verändert hätte....

Server unter HighSierra 10.13.6 , tomedo aktuell
Einfach nur lokal ausloggen und den ersten Login über die "Bildschirmfreigabe" machen :) - dann kommen die Fehler wieder
was meinen Sie genau mit "ausloggen". BS-Schoner mit PW anwerfen oder "abmelden". Aber abgemeldet habe ich mich noch nie...
Und ewig grüßt das Murmeltier: Dieses Fehlverhalten der ServerTools ist nach wie vor nicht beseitigt - ein tägliches Ärgernis.

Was soll ich mit einem AutoBackup, das nicht funktioniert? Meine Geduld ist nach über einem halben Jahr doch recht ausgeschöpft. Liebes Zollsoft-Team: Schafft schnell eine Lösung die auch läuft (am besten gleich mit verschlüsseltem Backup, s. anderen Ortes).
Beantwortet von (2.3k Punkte)
+2 Punkte
aktuell läuft bei mir wieder alles so, wie es soll... v1.70.0.1
Das Verhalten wechselt mit jedem Update. Mal laufen die Tools durch. Mal stürzen Sie bei jedem Backup ab. Mal stimmen die Zeiten, Mal wieder nicht... wir werden wohl warten müssen, bis der neue Server fertig ist.
4,812 Beiträge
8,516 Antworten
10,811 Kommentare
1,947 Nutzer