Seit dem letzten Update funktioniert unsere Aktionskette nicht mehr: 

Es kommt die Meldung: "Die Aktionskette kann nicht ausgelöst werden, da gerade eine andere Aktionskette ausgeführt wird" - wird aber nicht. Auf verschiedenen Arbeitsplätzen identisch gemeldet.

Bug oder User-Fehler?

Gefragt von (670 Punkte)
0 Punkte

3 Antworten

Wenn tomedo meint, dass grade eine Aktionskette ausgeführt wird, hat es damit höchstwahrscheinlich recht. Die Frage ist nur welche andere Aktionskette da dazwischenfunkt.

Zur Analyse könnten Sie für alle Aktionsketten die checkbox 'Zeige Verlauf' aktivieren und versuchen zu erkennen, welche Aktionskette da grade dazwischenfunkt.

Anderenfalls melden Sie sich bitte im support.
Beantwortet von (53.9k Punkte)
+1 Punkt
Hm, vor dem Update lief es und neue Aktionsketten haben wir vor Kurzem nicht eingerichtet...
Ich habe seit dem letzten Update das gleiche Problem. Wo finde ich "Zeige Verlauf"?

Bislang schlug eine AK die 2. Chronikerziffer vor. Bei Ablage sollte eine weitere AK dies erkennen und bei gesetzten Marker Geriatrie, die Geriatrieziffer anbieten. Leider funktioniert das nicht mehr und auch ein "Warten" von 20ms behebt das Problem nicht. Muss ich eine noch längere Wartezeit einstellen?
Sehr geehrter Herr Jörg,

in der Aktionskettenverwaltung gibt es den Haken ob Sie das Veerlaufsfenster sehen wollen oder nicht.

a) Grundsätzlich sollte keine Kette einfach so abbrechen ... wenn das der Fall ist wurde etwas nicht richtig bedacht.

b) die Wartezeit ist in der Regel nicht notwendig. Man braucht diese hauptsächlich dann wenn man eine SQL Bedingung nutzt und man sicher stellen muss das der client alle Daten an den Server gesendet hat. Es kann natürlich darauf ankommen was Sie tun, also konkret: ist die Bedingung die Sie überprüfen evtl zu der Zeit des Aktionskettenauslösers noch gar nicht auswertbar. Bsp: Sie haben 2 Aktionskettenauslöser. Der eine erstellt ein ToDo und der andere Auslöser überprüft das Todo. Und Sie starten beide Aktionskettenauslöser bei Karteiöffnen, dann passieren unklare Dinge durch die Gleichzeitigkeit der Aktionen.
Hallo Herr Zutz,

das Problem hatte ich auch häufig und immer hatte Tomedo Recht. Möglicherweise haben Sie irgendwo  zeitgleich eine andere Aktionskette ausgelöst. Grundsätzlich kann auch keine Aktionskette aus einer laufenden Kette starten, das geht dann nur mit einer Aktionskettenbedingung. Wenn Sie das über Aktionskettenbedingungen laufen lassen, gibt es manchmal das Problem von Endlosschleifen. Dies tritt dann auf, wenn in 2 aufeinanderfolgenden Aktionskettenbedingungen die gleiche Kette ausgelöst wird.

Die Fehlersuche ist extrem nervig und zeitaufwändig Der Tipp von Herrn Thierfelder kann helfen, die Fehlersuche etwas einzugrenzen, aber mann muss dann trotzdem viel herumprobieren.
Beantwortet von (20.4k Punkte)
Bearbeitet von
0 Punkte

Habe das Problem nun auch, wie wäre eine Abfrage bevor eine andere Aktionskette startet? Extra macht das ja niemand da zwei parallel laufende Aktionsketten ja nicht funktionieren? Da sollte ein Stop hin, kann nicht funktionieren?

Dieses Fenster ist nicht vergrösserbar und die Spalten nicht veränderbar. Es ist so nicht erkennbar was da passiert. Es fehlt ein g bei Bedingung aber irrelevant.

Da stimmt was nicht, ich habe nun die Aktionskette A  auf eine einzige Zeile reduziert. Die Aktionskette A hat eine einzige Zeile die über eine Bedingung Aktionskette B aufruft. Die Bedingung ist ein Text in einem CKE C.

Aktionskette A lässt sich aus der Kartei aufrufen und läuft fehlerfrei. Bedingung erfüllt, Aktionskette B wird ausgeführt.

 

Füge ich nun einen Auslöser hinzu: Aktionskette A wenn CKE C erstellt wird, startet die Aktionskette A aber es kommt

"Die Aktionskette kann nicht ausgelöst werden, da gerade eine andere Aktionskette ausgeführt wird"

Es gibt keine doppelten Auslöser, habe selbst gelöschte Auslöser geändert

Benennungen der Aktionsketten ist korrekt keine Leerzeichen, Namen sind eindeutig.
Beantwortet von (55.1k Punkte)
0 Punkte
Haben Sie Tomedo schon neu gestartet? Bei mir ist bei den AKtionsetten auch manchmal der Wurm drin und nach einem Neustart geht es wieder
Falls das Problem weiterhin besteht, zeigen Sie es bitte unserem Support - auf die Ferne ist es in dem Fall schlecht nachvollziehbar, wie und wo die schon laufende Kette ausgelöst wurde (und warum sie noch läuft).
Das Problem hat mir inzwischen Herr Klaproth gelöst. Ein Auslöser kann keine Aktionskette über einen Karteieintrag starten dann laufen zwei Aktionsketten parallel und der Fehler kommt. Was da genau passiert weiss ich nicht. Workaround ist Aktionskette die CKE anlegt und eine Kationskette startet.
11,293 Beiträge
17,958 Antworten
29,511 Kommentare
5,869 Nutzer