Beim Aufruf eines einfachen, neu erstellten Custom karteeieintrags hängt sich Tomedo ständig auf und reagiert nicht mehr.

Woran kann das liegen?

Das Problem hatte ich vor einigen Wochen schon einmal und möchte mir ersparen das Formular neu zu erstellen.

Vielen Dank für Anregungen und Unterstützung bei der Problemlösung

 

Grüße aus Husum

CK
Gefragt von (16.4k Punkte)
Bearbeitet von
+1 Punkt

1 Antwort

Bei umfangreichen custom Karteieinträgen hängen sich schwache Rechner auf. Wir haben (a la von Dr. Durst vorgestellte) sehr lange Karteieinträge, die schaffen nur die neusten Macs bei uns.
Haben Sie so etwas? Ist es der gleiche Mac und wenn ja, passiert es auch beim besten?

Ansonsten: Lokale Datenbank leeren und nochmals versuchen. Oder Aktivitätsanzeige anschalten, Karteieintrag aufrufen und Auslastung des Prozessors checken.
Beantwortet von (6.2k Punkte)
0 Punkte

Hallo Herr Müller

es handelt sich im konkreten Fall um einen kleinen custom Karteieintrag.

Mein Rechner hat folgende Leistungsmerkmale: iMac (21.5 Zoll, 2019); Prozessor 3,6 GHz Quad-Core Intel Core i3; 16 GB 2400 MHz DDR4.

Komplexe und sehr aufwändige Formulare funktionieren reibungslos auf allen Rechnern und MacBooks. Daran kann es also nicht liegen.

In diesem Zusammenhang ist mir aufgefallen, dass beim Überarbeiten von aufwändigen custom Karteieinträgen die markierten Inhalte der Vorauswahl nicht vollständig kopiert und auch nicht vollständig gelöscht werden. In Fällen mit sehr langen, über mehrere Textseiten laufenden Vorasuwahlfeldern, funktioniert es nur mit der Tastenkombinaktion: Shift+command+Pfeil runter. 

Auch funktionieren einzelne Komponenten, nach dem Zusammensetzen aber nicht mehr. Besonders die Fehlersuche bei If-kommandos ist sehr aufwändig. Ein Fehler durch Fehlen eines Unterstrichs wirkt sich an völlig anderen Stellen des Eintrag aus. 

Das betroffen custom Formular funktioniert an keinem Rechner. Gelöst habe ich das Problem mit realtiv wenig Aufwand, indem ich es auf den Desktop exportiert, reimportiert und den Inhalt der Vorauswahl für das zusammengestezte Textfeld gelöscht habe. Anschließend habe ich den in der textverarbeitung erstellten Text hineinkopiert, seitdem funktioniert es reibungslos. 

Wahrscheinlich treten solche Probleme selten auf, weil die Wenigsten mit aufwändigen custom Karteieinträgen arbeiten. 

Soll ich Ihnen das Formular schicke, damit Sie den Fehler analysieren können? Ähnliche Fehler sind bei mir häufiger aufgetreten und ich habe dann die Formular neu erstellt. Vielleicht kann man für die Zukunft daraus lernen. 

mit freundlichen Grüßen 

Christian Klaproth

Hallo Herr Klapproth,

ich hatte mal das gleiche Problem bei einem Custom-Kartei-Eintrag.

Hier war die Ursuche, dass ich ein Textfeld zusammengesetzt - nicht editierbar (neu) verwendet habe. Nach dem Umstellen auf das "alte" Textfeld zusammengesetzt - nicht editierbar war das Problem gelöst.

Oder haben Sie schon eine andere Lösung finden können?

Viele Grüße

Andreas Tenzer
Hallo Herr Tenzer

Danke für Ihren Tipp. So einfach wie bei Ihnen war das bei mir leider nicht. Auch hatte ich heut ein ähnliches und sogar schwereres Problem.

Konnte mir bei Ersteren Problem behelfen, indem ich das Formular auf den Desktop exportiert, reimportiert und den Inhalt der Vorauswahl für das zusammengestezte Textfeld gelöscht habe. Anschließend musste ich nur noch den in der Textverarbeitung erstellten und dort sicherheitshalber abgespeicherten Text hineinkopiert, seitdem funktioniert das Formular reibungslos.

Heute hatte ich mit einem äußerst aufwändig erstellten Custom Formular (vile Berechnungen und If- Kommandos), ein noch größeres Problem, dass leider gar nicht mehr in der Entwurfsansicht zu öffnen war. Aus der Karteizeile konnte ich es jedoch öffnen und befüllen, was aber leider nicht ausreichte, weil es noch fertig war und ich noch finale Änderungen vornehmen wollte. Leider ging gar nichts mehr, weil sich Tomedo sofort beim Öffnen der Entwurfsansicht regelmäßig aufgehängt hat.

Den Inhalt des zusammengesetzten Textfeldes konnte ich ebenfalls nicht mehr löschen, so dass mir nicht anderes übrig blieb, als das Formular komplett neu zu erstellen. Aufgetreten war der Fehler beim Positionswechsel eines Start-Stopp Zeitfeldes, das ich als Schnitt-Naht Zeit in der Vorlage für meine Op Berichte eingebaut habe.

Aus den schlechten Erfahrungen der Vergangenheit habe ich den Inhalt des zusammengesetzten Textfeldes in einem Textdokument gesichert und konnte das reimportieren, nachdem ich das ganze Formular neu angelegt habe. Anhand eines Screenshot von der Formularansicht ging das mit relativ geringem Zeitaufwand.

Dennoch würde mich brennend interessieren, woran der Fehler liegt.

Grüße aus dem Norden

CK
9,858 Beiträge
15,972 Antworten
24,961 Kommentare
4,580 Nutzer