Microsoft wird seine Standardauthentifizierung im Laufe des Jahres einstellen. Ab dem 1. Oktober 2022 wird die Standardauthentifizierung für die Protokolle Outlook, EWS, RPS, POP, IMAP und EAS in Exchange Online deaktiviert. SMTP-Authentifizierung wird ebenfalls deaktiviert, wenn sie nicht verwendet wird.
https://docs.microsoft.com/de-de/exchange/clients-and-mobile-in-exchange-online/deprecation-of-basic-authentication-exchange-online

https://techcommunity.microsoft.com/t5/exchange-team-blog/basic-authentication-and-exchange-online-september-2021-update/ba-p/2772210

Da die Anmeldung der IMAP und SMTP Verbindungen zu Microsoft Exchange Servern betroffen ist, müsste tomedo die moderne Authentifizierung in den Emailkonten übernehmen, wie das bei MAC OS schon umgesetzt ist: https://support.apple.com/de-de/guide/deployment/dep158966b23/web
 

Bis wann plant zollsoft die Integration der modernen Authentifizierung in tomedo?

Gefragt in Wunsch von (360 Punkte)
Kategorie geändert von
0 Punkte

1 Antwort

Beste Antwort
Die Authentifizierung über OAuth2.0 (moderne Authentifizierung) ist bereits implementiert und wird vorrausichtlich bis zum 31.05.2022 zur Verfügung stehen. Gerade testen wird noch intern und konfigurieren für verscheidene Provider.
Beantwortet von (480 Punkte)
ausgewählt von
0 Punkte
Perfekt. Herzlichen Dank für die rechtzeitige Umsetzung, damit bleibt genug Zeit zum Testen.

Sehr geehrter Herr Huster,

die Implementierung ist da - es gibt für den Provider (hier Office 365) keine hinterlegte Konfiguration.

Wo kommt diese her? Wo wird das eingestellt oder ist das noch nicht von zollsoft umgesetzt?

Besten Dank für eine Info.

Sehr geehrter Herr Mildner,

wir arbeiten derzeit noch an Konfigurationsproblemen mit den verschiedenen Providern von Microsoft (daher die Fehlermeldung) und werden zeitnah eine Lösung zur Verfügung zu stellen.

Freundliche Grüße,

Constantin Huster

Hallo Herr Huster,

nachdem für Office365 noch kein Auth2.0 in tomedo hinterlegt ist (wir das Verfahren aber getestet haben) ist ein Rücksprung zur Standardauthentifizierung nicht möglich:

An der Kombi Email/Passwort liegt es nicht, dass haben wir bereits xfach getestet und über andere Wege mit Login erfolgreich abschliessen können. Mit dem Rücksprung auf die Standardauthentifizierung hat sich irgendetwas aufgehängt - mit der Folge, dass kein Zugriff mehr zur Aktualisierung der Emails stattfindet.

Alle anderen Postfächer, die wir nicht mit Auth2.0 getestet haben, funktionieren einwandfrei.

Microsoft hat die moderne Authentifizierung bereits standardmäßig auf allen Postfächern aktiviert - über das Admin panel Panel haben wir das aktuell aber wieder deaktivieren können.

Haben Sie einen Workaround? 

Wir haben inzwischen die Log-Protokollierung von Microsoft erhalten, der Account meldet sich bei Microsoft gar nicht an.

Lediglich der Login über Webbrowser ist erfolgreich und registriert.

Inzwischen sind leider alle Accounts offline, kann also nicht an der Einzeleinstellung liegen.

Microsoft aktiviert gerade bei allen Office 365 Anwendungen zwangsweise für 2-3 Tage die moderne Authentifizierung. Obwohl abgeschaltet, scheint die Standardauthentifizierung nicht mehr zu funktionieren.

Bitte dringend OAuth2.0 für Office365 als Template in tomedo hinterlegen.

Liebes tomedo Team,

wir hatten schon vor Monaten auf die Umstellung hingewiesen. Microsoft hat kurzerhand für 48 Stunden die Standardauthentifizeriung abgeschaltet. Leider funktioniert aktuell das vorzeitige Rücksetzen vor der Frist nicht bei unserem Kunden. Bitte rüsten Sie schnellstens das OAuth2.0 Template nach!

Hallo Herr Mildner,

ich arbeite an einer Lösung. Leider habe ich auch mir Änderungen von Microsoft zu kämpfen. Ich werde mich spätestens morgen wieder dazu melden und Ihnen mitteilen wann ein Lösung verfügbar ist.

Freundliche Grüße,

Constantin Huster
Vielen Dank. Es ist saublöd, wenn Microsoft Fristen angibt und dann mal testweise die Zugänge abschaltet, damit man auf die Änderung aufmerksam wird. Wir haben die  OAuth2.0 über das Admin Panel abgeschaltet, mit der Folge dass gar nichts mehr geht (IMAP teilaktiviert - geht auch nicht). Wir sind gerade mit allen Support Teams am Arbeiten, weil jetzt minutenweise europaweit immer meht unserer Kunden betroffen sind.

Ich halte sie ebenso auf dem Laufenden.

Über die Konsole in Office 365 haben wir die Standardauthentifizierung wieder aktivieren können.

Es funktioniert inzwischen wieder überall, nur nicht in tomedo. Wieso gibt es bei den Konteneinstellungen nun 2 verschiedene Passwörter zu hinterlegen, die aber nicht greifen und plötzlich verschwinden?

Kann da doch etwas an den Settings hängen?

Das ist ein GUI-Bug und hat nichts mit den Einstellungen zu tun. Man kann nur ein Passwort je Acount hintelegen. Wenn Sie von Passwort zu OAuth2.0 wechseln und dann wieder zurück sollte der GUI- Bug weg sein. Eventuell noch mal den Port und die Verschlüsselungsmethode prüfen, die kann für OAuth2.0 ander sein als für Passwort.

Freundliche Grüße,

Constantin Huster
Wenn das ein GUI Fehler ist, ist die Fehlerquelle ausgeschlossen.

Wir haben folgendes Lagebild:

Der Server wurde im Rahmen der wöchentlichen Wartung gestern Abend neu gebootet.  

Der Email Ausfall muss daher rühren.  Eventuell sind Sicherheitstoken durch den Reboot abgelaufen.

Die Telemetriedaten und Log Dateien zeigen, dass sich der OTK über Standard Authenthifizierung  anmeldet und versendet. Gleicher Acoount, gleiche Settings.

Von Tomedo gibt es in den Log Dateien bei Microsoft keinerlei Hinweis auf einen fehlgeschlagenen Anmeldeversuch, obwohl in Tomedo ein Authentifizierungsfehler erscheint.  Leider ist im Tomedo log nichts genaueres zu finden.  

Mit der Neuanmeldung Standart AUTH scheint es nicht zu klappen. Eingeloggte Clients bleiben weiterhin verbunden und senden und empfangen.

Wir haben überprüft, ob die IP Adresse blacklistet ist.  Negativ. Zur Sicherheit die IP gewechselt.  Negativ.   Eine Annahmerichtlinie ist nicht hinterlegt.  Sonst könnte der OTK aus Ihrem Hetzner Data Center auch nicht senden.

Wir sind etwas ratkos. Microsoft verweist aktuell auf die Verfahren der 48 Stunden Ubterbrechung.  Wir haben entsprechend alles umgesetzt.  Negativ.  

Eventuell ist in Azure die Rechte Federation noch nicht synchronisiert.
Seit 22.30 Uhr loggen sich die Accounts wieder ein. Das lag definitiv an Microsoft. Wir hatten inzwischen IMAP Konten außerhalb von Office 365 testweise angehängt, die taten einwandfrei.

Wir haben unendlich viel über die Powershell und die GUI im Admin Bereich an Einstellungen probiert. Da das aber so pünktlich wieder funktionierte, haben wir entweder eine Synchronisation der Server im Verdacht oder die abgeschaltete Frist ist vorüber.

Wir sind Ihnen sehr dankbar, wenn OAuth2.0 bald funktionieren könnte. Wir rechnen da mit weiteren Komplikationen bis das implementiert ist und wollen das rechtzeitig vor den bayerischen Ferien und an einem Wochenende testen und umstellen, wenn nicht  medizinischer Hochbetrieb ist.

Diese "Testunterbrechung" von Microsoft ist völlig aus dem Ruder gelaufen und auch unsinnig gewesen, da wir frühzeitig auch bei tomedo, zu OAuth2.0 angefragt hatten und vorbereitet sind.

Besten Dank wie immer für das wirklich immer schnelle Feedback auf unsere Fragen.
Schön zu lesen, dass sich die Account wieder einloggen können. Meine Testauccounts gehen leider noch nicht  wieder (allerging bei keiner Anwendung, die ich versuch habe. Daher sehr wahrscheinlich ein Microsoft Problem). Danke für Ihr feedback zu dem Thema. Ich weiß aus eigenen Erfahrung wie komplex sich die Konfigurationsarbeit bei solchen Problem gestalten kann. Ich versuche OAuth2.0 so schnell wie möglich umzusetzen und halte Sie auf dem laufenden.

Freundliche Grüße,

Constantin Huster
Die Änderungen am Code für OAuth2.0 mit Microsoft sind abgeschlossen (Problem ließen sich nicht durch Konfiguration allein Lösen). Das läuft jetzt noch eine Runde durch interne Testing und kommt dann einem der nächsten updates.

Die Freundliche Grüße,

Constantin Huster
Guten Morgen zusammen,

in welcher Tomedo-Version wird OAuth für Microsoft umgesetzt sein?

Freundliche Grüße

Eric Schindler
HNOmedic
Hallo Herr Schindler,

wir sind inzwischen auf Version 1.113.0.17 - da geht es noch nicht. Im Changelog für die nächste Version ist zu OAuth nichts vermerkt.

Viele Grüße

Michael Mildner
GEMIFYE / MET.online
10,487 Beiträge
16,876 Antworten
27,130 Kommentare
5,003 Nutzer