Hallo zusammen,

folgender Bug ist mir gerade im "Textfeld zusammengesetzt nicht editierbar (v2)" bei der Konfiguration des Anzeigetextes begegnet:

 

Folgende Grundsyntax:    $($[v1]$,$[v2]$,KOMMA_BEGIN""_ENDE"")$

 

Enthält entweder der BEGIN- oder der ENDE-Text ein Komma, ist die Syntax korrupt.

 

Beispiel:

$($[v1]$,$[v2]$,KOMMA_BEGIN"Hallo, wie gehts"_ENDE"tschüss")$ funktioniert nicht, ohne Komma gehts es.

 

Ich arbeite noch mit v1.118.0.19

 

Ist der Fehler schon bekannt?

 

Viele Grüße aus Augsburg

Andreas Tenzer
Gefragt in Bug von (23.8k Punkte)
0 Punkte
Hallo Andreas

das funktioniert genauso wenig, wie die Satzzeichen in einem Mehrfachauswahlfeld. Auch ein verstecktes Textfeld scheitert, das man als Begintext $[Textfeld]$ einsetzt, allerdings auch nur dann, wenn es als Trennzeichen ein Komma enthält.

Man kann dann tricksen indem man ¸  (⇧ ⎇ r)

oder ˛ (⇧ ⎇ ,) verwendet.
Lieber Christian,

vielen Dank für den Workaround.

Aber sehr schade, dass es nicht ohne geht. Ist sicherlich eine schwer vorhersehbare Stolperfalle für einige Nutzer.

 Viele Grüße

Andreas
Da habe ich mir auch schon die Zähne erfolgreich dran ausgebissen, genau so wie an einigen anderen Stolperfallen.

Mit etwas Geschick kann man das aber umgehen. Bei der Übernahme des Kommazeichens hat man an zahlreichen Stellen Probleme

1 Antwort

Beste Antwort
Sehr geehrter Herr Tenzer,

das ist leider eine der Limitierungen an der Syntax.
Beantwortet von (83.8k Punkte)
ausgewählt von
0 Punkte
16,244 Beiträge
24,075 Antworten
42,477 Kommentare
12,244 Nutzer