Unser Update zur aktuellen Situation

Liebe tomedianer,

aus gegebenem Anlass möchten wir Ihnen versichern, dass wir alles dafür tun, um Ihnen in den kommenden Wochen auch weiterhin in gewohnter Art und Weise zur Verfügung zu stehen.

Gleichzeitig ist es unsere Priorität, die Gesundheit und das Wohlbefinden unserer Nutzer und Mitarbeiter zu schützen und unseren Teil zur Eindämmung der Verbreitung von COVID-19/Corona beizutragen. Aus diesem Grund haben auch wir ab sofort einige technische und organisatorische Maßnahmen getroffen, sodass u.a. ein Großteil unserer Mitarbeiter inkl. unserem Supportteam von zu Hause aus arbeiten kann. Wir bitten um Ihr Verständnis, falls es dadurch evt. zu längeren Wartezeiten an der Hotline bzw. bei der Beantwortung von E-Mail und/oder Forumsanfragen kommt.
Es gibt Probleme bei dem Verbinden eines Netzwerkordners. (gesehen von und zu einem Sierra Rechner). Wenn man dies automatisch machen will, also via Nutzer und Passwort (zB mit dem Finder und cmd+k oder Mountskript), muss man immer die Eingabe der Nutzerdaten nochmal bestätigen. Das ist nervig, aber bisher gibt es kein Workaround.
Gefragt von (38k Punkte)
0 Punkte
Kann ich bestätigen, habe auch im Schlüsselbund am Rechner und in der Cloud schon die Schlüssel gelöscht aber bringt nichts. Dachte das ist vielleicht weil ich keinen Clean Install gemacht habe aber dann ist es wohl generell ein Sierra Problem.

5 Antworten

.
Beantwortet von (38k Punkte)
0 Punkte
Nach dem Sierra Update auf .1 immer noch. Gibt es jetzt vielleicht ein Workaround?
Beantwortet von (38.7k Punkte)
0 Punkte
Naja, man kann evtl mit ein Applescript ein terminal Befehl aufrufen worin mit root rechten der direkte mount Befehl aufgerufen wird ... sehr unsicher.
Wenn man ein Appleskript benutzt, kann man - statt über den Finder zu mounten - die URL inkl. Nutzer und Passwort an Safari geben. Dann kommt keine erneute Abfrage. Allerdings wird dadurch der Safari gestartet, was insgesamt möglicherweise etwas langsamer ist, als über den Finder zu gehen.
Doch kommt sie Daniel, unter Sierra eben schon. Bei mir mountet ein Applescript die Netzlaufwerke. Das Passwort wird eingegeben aber ohne Bestätigung läuft nix.

use framework "Foundation"
use scripting additions
current application's NSThread's sleepForTimeInterval:10
try
    mount volume "smb://xxx:xxxk!@192.168.1.10/Devonsync"
end try
try
    mount volume "smb://xxx:xxx!@192.168.1.10/labor-eingang"
end try
try
    mount volume "smb://xxx:xxx!@192.168.1.10/info"
end try
Probier mal:

tell application "Safari" to open location "smb://xxx:xxxk!@192.168.1.10/Devonsync"

oder auch:

do shell script "open -a Safari smb://xxx:xxxk!@192.168.1.10/Devonsync"
Danke Daniel aber genau so. Passwort wird eingetragen wird aber nicht automatisch bestätigt.
Mit einem neuen Applescript zum mounten eines Verzeichnisses kann man das Problem umgehen:

http://forum.tomedo.de/index.php/1009
Beantwortet von (38k Punkte)
0 Punkte
Muss Tomedo dafür laufen? Wäre dann schwierig beim Start auszuführen.

Um das Mount-Skript bei Rechnerstart unter Sierra automtisch auszuführen kann man folgendermaßen vorgehen:

1.) Script-Editor starten:

2.) Script schreiben (verinfachtes Beispielskript, für richtiges Script s. http://forum.tomedo.de/index.php/1009 )

3.) Script als App speichern:

 

4.) Daraufhin sollte an der ausgewählten Stelle eine .app-Datei enstehen:

5.) Diese kann man nun zu den Anmeldeobjekten des Rechners hinzufügen.

Beantwortet von (34.2k Punkte)
0 Punkte
Möglich ist es auch das Skript in tomedo zu integrieren und es bei tomedo start auszuführen.
prima step-by-step Anleitung!

Ha! Die Lösung für die Passwortabfrage beim Autostart eines mount-Skriptes gefunden. 

Im Benutzerverzeichnis einen Ordner Server und darin den Ordner Drive erstellen. 

 dann mounten mit ~/Server/Drive

Beispiel:

 

try

mount volume "smb://Benutzer:Pass@192.168.x.xx/Devonsync ~/Server/Drive"

end try

 

Funktioniert wie eine Eins. Gott sei dank das hat mehr genervt als die Rechnungsabfrage von Tomedo beim Öffnen einer Kartei. Wann ist die eigentlich endlich weg?

 

PS: funktioniert an nicht jedem meiner Rechner. Habe wohl noch etwas an meinem Privaten Rechner gemacht.

PPS: man scheint OSX 10.12.2 dazu zu brauchen. An einem Rechner installiert und funktioniert jetzt auch dort. Also nicht das nervige Abrechnungsfenster von Tomedo sondern der Automount.

Beantwortet von (38.7k Punkte)
Bearbeitet von
+1 Punkt
Hallo Peter!

Ich kenne mich mit diesen Skripten und Befehlen noch nicht so gut aus...

Wie heißt denn jetzt das entferne Volume bzw. Ordner, den dieser Befehl mountet?? 'Devonsync' ?

und lokal habe ich einen (leeren?) Ordner 'Drive' in einem Ordner 'Server' im Benutzerverzeichnis? Habe ich das so richtig verstanden?

Meins sieht so aus, als App speichern im script editor. Es wartet 10 Sekunden beim start. Genau die leeren Ordner anlegen. Die Verzeichnisse sind auf dem Server friegegeben und werden gemountet. Devosync, labor-eingang und info (schwarzes Brett)

use framework "Foundation"

use scripting additions

current application's NSThread's sleepForTimeInterval:10

try

mount volume "smb://siehe oben/Devonsync ~/Server/Drive"

end try

try

mount volume "smb://siehe oben/labor-eingang ~/Server/Drive"

end try

try

mount volume "smb://siehe oben/info ~/Server/Drive"

end try

5,551 Beiträge
9,771 Antworten
12,570 Kommentare
2,281 Nutzer