Ich versuche gerade, in einem Custom-Karteieintrag das Datum der letzten beiden CRP-Bestimmungen mit dem Briefkommando $[laborwert LAB CRP %d 2]$ einzutragen. Das Ergebnis ist – nichts. Den CRP-Wert und die Einheit lassen sich mit $[laborwert LAB CRP %w_%e 2]$ ermitteln, das Datum aber nicht. Das, obwohl ein Abnahmedatum bei dem entsprechenden Laborwert eingetragen ist.

Dasselbe Verhalten zeigt sich auch, wenn ich das Kommando in einer Briefvorlage verwende.

Kennt jemand das Problem? Bug?

Frohe Ostern an alle!

Gefragt von (1.8k Punkte)
0 Punkte

3 Antworten

Also ich nutze $[laborwert LAB CRP %w_%e_%d 2]$ und das läuft problemlos und bringt die letzten beiden Werte inkl. Datum.
Beantwortet von (1.3k Punkte)
+1 Punkt
Das ist ja interessant! Diese Kombi tut bei mir auch nicht, sprich es werden nur Werte und Einheit, aber kein Datum ausgegeben.

Welche Version von tomedo nutzen Sie denn? Bei mir läuft 1.95.0.8 und .9 und auf beiden tuts nicht.
OK, jetzt hab ich, glaub ich, den Fehler gefunden:

Wenn bei einem Laborwert im Befund kein echtes Abnahmedatum steht, sondern "Abnahmedatum (best fitting)" – also wahrscheinlich das Eingangsdatum im Labor, dann kommt mit %d auch kein Datum zurück. Bei Befunden mit "echtem" Abnahmedatum tuts. Es liegt also wohl an den (unvollständigen) Labordaten.

Daher Frage an Zollsoft: Könnten Sie mit dem Parameter %d immer ein Datum zurückgeben, also ein fallback einbauen auf das "best fitting" oder das Eingangsdatum im Labor?
Beantwortet von (1.8k Punkte)
0 Punkte
Sehr geehrter Herr Dr. von Keller,

ich gebe die Frage direkt mal an unseren verantwortlichen Entwickler und melde mich zeitnah.

Viele Grüße

Christian Honey

tomedo Produktmanagement
Sehr geehrter Herr Dr. von Keller,

ich freue mich, Ihnen mitteilen zu können, dass ihr Wunsch in der Version 1.95.0.12 umgesetzt sein wird. Diese wird in wenigen Tagen ausgerollt.

Viele Grüße

Christian Honey



tomedo Produktmanagement
Beantwortet von (280 Punkte)
+1 Punkt
Super! Das ging ja superschnell! Dankeschön!
7,516 Beiträge
12,534 Antworten
17,526 Kommentare
3,093 Nutzer