Hallo,

ich erstelle gerade einen CustomKarteiEintrag um unsere Röntgenaufträge einfacher zu generieren. Gerne stelle ich das Formular nach Fertigstellung auch im Tauschcenter zur Verfügung.

Dabei möchte ich zusammengesetzte Textfelder erneut mittels dem Kommando $($[zusammengesetztesFeld1]$,$[zusammengesetztesFeld2]$,NEWLINE)$ in einem weiteren "Textfeld zusammengesetzt (neu)" ausgeben. Dies funktioniert jedoch leider nicht. Als Ausgabe in dem neuen Feld werden mir die Variablennamen in jeweils einer Zeile ausgegeben.

Wie kann ich das Problem lösen?
Gefragt von (2.2k Punkte)
0 Punkte

2 Antworten

Seh geehrter Herr Stenger,

die Felder werden von oben nach unten ausgewertet. D.h in der Customformularverwaltung muss das Feld mir dem Variablenamen "zusammengesetztesFeld1" und "zusammengesetztesFeld1" vor (über) dem finalen Feld stehen.

Wenn in dem finalen Feld dann aber so etwas steht (ich denke das lese ich aus Ihrer Beschreibung, da Sie Variablenname schrieben)

$[zusammengesetztesFeld1]$
$[zusammengesetztesFeld2]$

Dann haben Sie im Variablennamen sich vertippt.

Sollte aber der Inhalt alles richtig sein und wirklich "nur" der Zeilenumbruch falsch sein, ... würde ich auf Tippfehler tippen. Versuchen Sie mal ob anstelle von NEWLINE ein KOMMA geht.

Beantwortet von (47.3k Punkte)
0 Punkte

Guten Herr Thierfelder,

die Reihenfolge stimmt würde ich sagen und bei den Variablen würde ich sagen, ist auch kein Fehler. Anbei ein Screenshot. Ich kann auch der Einfachheit halber den Karteieintrag in das Tauschcenter laden.

KOMMA führt zu dem gleichen "falschen" Ergebnis.

Beantwortet von (2.2k Punkte)
0 Punkte
hm, sieht richtig aus. mein tipp: schaunen Sie mal den Variablennamen "zus_schulter" an, ist da evtl ein leerzeichen oder so mit drin?
nein, ein Leerzeichen ist nicht drin. Ich habe extra um Fehler zu vermeiden die Variablennamen kopiert.
tja, der schuldige ist gefunden ... da hab ich wohl Mist gebaut und die Ersetzung vergessen. Kommt in der  v1.89.0.3
VIELEN DANK!!!
Hallo Herr Thierfelder,

nach dem Update funktioniert das bei dem "zusammengesetzten Textfeld nicht editierbar (neu)". Vielen Dank dafür. Leider funktioniert es aber nicht bei dem "zusammengesetzten Textfeld nicht editierbar". Mein Problem ist wie in einem anderen Thread beschrieben, dass ich eine Auflistung aus einer Mehrfachauswahl ohne Komma zwingend wegen GDT benötige. Die Kommandos Leerzeichen, Komma, Kommaund funktionieren nur bei dem "alten" zusammengesetzten Textfeld, nicht jedoch bei dem neuen. Können Sie das Problem auch noch beheben?

Vielen Dank schon mal

Sehr geehrter Herr Stenger,

1) ich werde nichts mehr an der alten Option ändern, da die sozusagen bestandsschutz hat und so funktionieren soll (in einer komischen Art) wie bisher. Wenn ich diese ändern würde wären viele u.U. Konfigurationen falsch.

2) die neue Option funktioniert wie sie soll. Sie kann auch (bedingt) verschachtelt ersetzen und macht genau das was Sie soll. D.h. es werden die einzelnen Felder in $(A,B,TRENNZEICHEN)$ - also A und B - genommen, ausgewertet was es ist und dann wird dieser Inhalt (egal was es ist, auch was mit Komma etc und es wird kein Komma oder Leerzeichen bereinigt) genau so genommen und dann werden abhängig vom TRENNZEICHEN die einzelnen Felder wieder zusammengesetzt.

Hier ein Beispiel was geht und was nicht geht:

3. GDT ... was wollen Sie da machen. Ich denke das mit dem Kommas klingt komisch

Hallo,

ich will einen Röntgenauftrag übergeben. Inzwischen habe ich es durch die Kombination von altem und neuen Feld hinbekommen. 

Leider muss ich Ihnen widersprechen. Das neue Feld macht nicht genau das, was es soll (wenn es überhaupt so vorgesehen ist). Ich möchte ein Mehrfachauswahlfeld mittels Kommando ausgeben. Dabei wird unabhängig vom Kommando immer ein Komma gesetzt. Siehe Screenshot. 

Also für mich funktioniert es genau wie es soll. Es wird $[test]$ ausgewert und da kommt der string "1, 2, 3" raus. Und dann wird aus diesem einen String eine Auflistung gemacht. also "1, 2, 3".

Sie wollen das der String interpretiert wird als Liste... aber das ist nicht das programmierte Verhalten. Diese "UND" Variante müsste in das Mehrfachauswahlfeld... oder sie machen den Trick via der alten Variante (yes) und haben dann Glück das ich die alte Variante nicht mehr angepasse wink.

Hallo Herr Thierfelder

Die Beobachtung von Herrn Stenger kann ich nur bestätigen. Bei der Verwendung eines Mehrfachauswahlfeldes werden die einzelnen Einträge im Textfeld grundsätzlich durch ein Komma separiert. Will man die ausgewählten Pararmeter in einem zusammengesetzten Textfeld haben und dort die Trennnzeichen modifizieren,  funktioniert das im Textfeld zusammengesetzt nicht editierbar neu allerdings nicht. Dort wird genau der Inhalt vom Textfeld mit einem Komma als Trennzeichen übernommen. Erst sobald man mehr als 1 Variable übernimmt, werden die einzelnen Variablen wie mit dem Kommando vorgegeben, getrennt. Hat man nur eine Variable und möchte die Kommaseparierung ersetzen funktioniert das nur mit dem "alten zusammengesetzten Textfeld" Das alte sollte man also unbedingt beibehalten, wenn man den String ohne Kommaseparierung übernehmen und modifizieren will. Der Unterschied ist allerdings nur sehr schwer zu erkennen und es benötigt deshalb viele Versuche bis jemand wie unsereins dahinter gekommen ist.

Wir werden die Namen der 2 Varianten anpassen und das Handbuch erweitern. "neu" ist zu missverständlich. So in der Art:

Textfeld zusammengesetzt nicht editierbar -> Textfeld zusammengesetzt nicht editierbar (interpretierend)

Textfeld zusammengesetzt nicht editierbar neu -> Textfeld zusammengesetzt nicht editierbar (tiefe pure textersetzung)

7,642 Beiträge
12,755 Antworten
17,918 Kommentare
3,153 Nutzer