IT Support
Seit kurzem lässt sich das Linux Betriebssystem auf dem Server nicht mehr über das GUI des tomedo Servers aktualisieren:

Welche Aktualisierungsstrategie schlägt zollsoft hier vor? Wie es aussah, sind die Pakete vorab von zollsoft geprüft und über ein eigenes repository zur Verfügung gestellt worden.
Freundliche Grüße
Michael Mildner
Frank Reinprecht
Hallo Herr Mildner,
es gab ein paar Änderungen bei uns in den Repos, eigentlich sollte über die AutoUpdate Funktion des Systems das Paket tomedo aktualisiert worden sein und diese Änderungen dem System mitteilen. Die Buster Pakete wurden aus unserem Repo entfernt und werden jetzt von den offiziellen Quellen bezogen.
Warum das genau bei Ihnen nicht passiert ist, müsste man per Aufschaltung prüfen.
Sie können diesen Fehler aber beheben, indem Sie unter /etc/apt/sources.list.d/tomedo.prod.list den ersten Eintrag für buster mit einem "#" Zeichen kommentieren.
Gern können Sie sich auch mit einem Ticket an unseren Support wenden, dort wird man per Teamviewer eine Verbindung herstellen und wir prüfen, warum die Änderung bei Ihnen nicht ankam und nehmen sie gleich mit vor.
Vielen Dank und mit freundlichen Grüßen,
Frank Reinprecht
IT Support
Hallo Herr Reinprecht,
herzlichen Dank für die superschnelle Rückmeldung und die Information.
Das Auskommentieren in der Datei war erfolgreich, wir haben eine lange Update Liste nach einem Neustart erhalten!

Mit freundlichen Grüßen
Michael Mildner
IT Support
Darf ich so unverschämt sein und noch eine Nachfrage zum Update stellen?
Linux Debian Buster endet der Support Ende Juni 2024. Gibt es von Seiten zollsofts einen Updateplan für die tomedo Server zur Migration auf eine der beiden nächst höheren Linux Distibutionen?
Vielen Dank.


Frank Reinprecht
Hallo Herr Mildner,
sehr schön, wenn das Problem damit behoben ist!
Ein Update auf Debian 12 Bookworm (mit Zwischenschritt auf 11 Bullseye, da nicht direkt upgradebar) ist bei uns gerade "im Ofen" und wir hoffen es bald freigeben zu können.
Es muss noch ein paar Tests durchlaufen und durch die QA, aber behalten Sie diesbezüglich die Newsletter im Auge, in denen wir die Verfügbarkeit ankündigen werden.
Ein schönes Wochenende!
Frank Reinprecht
IT Support
Hallo Herr Reinprecht,
wie ist der Stand bezgl. Update Server-Betriebssystem? Immerhin wird seit Juli die installierte 10er-version nicht mehr mit Sicherheitspatches versorgt.
Danke für ein Update.
Michael Mildner
Olaf Wehmeyer
Ich habe selbst gar keinen Zugriff auf die obige GUI des tomedo servers. Diese wurden uns bei Einrichtung gar nicht mitgeteilt und auch die IT-Betreuung hat dazu keine Zugangsdaten. Bisher habe ich nur zollsoft-Mitarbeiter sich dort einloggen sehen. Wenn ich allerdings dort regelmäßige Updates der Linuxversion vornehmen müsste, wäre das ganz gut zu wissen gewesen. Mein Server ist auch noch auf Linux 10.
Dr.Christoph Hainich
Das selbe würde mich auch für die MacOS-Server-Version interessieren: Da wird Sonoma von Apple noch vollständig gepflegt (und bei den Sicherheitsupdates mitangeboten), aber langsam wäre die Freigabe für Sequoia 15.3.1 mal fällig!
Viele Grüße aus dem weißen Harz
Frank Reinprecht
Hallo Herr Mildner,
die Freigabe des Updates steht kurz bevor. Wir haben ausgiebige interne Tests vorgenommen, schulen aktuell noch Support und Technik und sind fast fertig mit allen Vorbereitungen zur Veröffentlichung. Mit etwas Geduld, können Sie bald aktualisieren.
Uns ist für dieses Update unserer Linuxsserver die höchste Priorität, dass es reibungslos und fehlerfrei funktioniert, daher die ausgiebigen Tests, die sich hoffentlich für Sie als unserer Kunden in einer reibungslosen Migration auszahlen.
Mit freundlichen Grüßen,
Frank Reinprecht
IT Support
Guten Morgen,
wir erhalten seit heute auf dem Linux Debian Server Aktualisierungsfehler. Das buster Update ist schon lange unter /etc/apt/sources.list.d/tomedo.prod.list auskommentiert.
Was empfehen Sie? Server Support Team anrufen oder gibt es für die Datei einen neuen Update Pfad?

Viele Grüße
Michael Mildner
Frank Reinprecht
Guten Morgen Herr Mildner,
leider hat uns die Änderung in den Debian 10 Buster Repos etwas überrascht. Ein Fix dafür ist auf dem Weg und wird zeitnah diese Woche ausgerollt. Entschuldigen Sie etwaige Schwierigkeiten deswegen.
Wenn Sie es manuell schon beheben möchten, müssen Sie einmal im Terminal auf dem Linux-Server mit
sudo nano /etc/apt/sources.list
die Datei öffnen und wie folgt editieren:
Die Zeile security.debian.org kommentieren und für die beiden anderen Zeilen deb.debian.org zu archive.debian.org ändern. Zuletzt noch einmal "sudo tomedoServerUpdate" ausführen und die Meldung sollte behoben sein.

In diesem Zusammenhang wird Ihrerseits die Frage nach Debian 12 Bookworm erneut aufgekommen sein. Das Update wird aktuell in kleinen Schritten für zufällig ausgewählte Praxen aktiv geschalten. Eine Freischaltung Ihrer Kundennummer wäre auf Wunsch ohne weiteres möglich.
Mit freundlichen Grüßen,
Frank Reinprecht
IT Support
Guten Morgen Herr Reinprecht,
besten Dank für die rasche Rückmeldung. Wir werden die Änderungen heute Mittag durchführen und testen.
Gerne würden wir uns für das Update auf Debian 12 bewerben. Kd. Nr. 40082.
Mit freundlichen Grüßen
Michael Mildner
IT Support
Hallo Herr Reinprecht,
die Änderungen haben funktioniert, das System zeigt sich "aktualisiert" an, aber jetzt melden die Container einen Fehler:

Frank Reinprecht
Guten Abend Herr Mildner,
das ist ein Bug im Cockpit, der auf die Container selbst aber keine Auswirkungen hat. Mit dem Upgrade auf Debian 12 wird es behoben, evt. kann ich den Fix auch noch auf Debian 10 bringen. Solange sie die pgadmin-Oberfläche noch aufrufen können, ist nur das Plugin vom Cockpit betroffen, dass die Container-Übersicht anbietet.
Prima, wenn das apt-Problem erstmal gelöst ist. Bzgl. des Cockpit-Docker-Plugins schaue ich.
Mit freundlichen Grüßen,
Frank Reinprecht
IT Support
Hallo Herr Reinprecht,
besten Dank für die Infos. Vielleicht graden wir dann doch bald auf Debian 12 hoch!
Schönen Abend und Danke für das immer schnelle und qualifizierte Feedback :-)
Mit freundlichen Grüßen,
Michael Mildner
IT Support
Hallo Herr Reinprecht,
unsere Debian 12 Bookworm hat seit dem letzten Update im Cockpit einen Repository Fehler:

nach einem Refesh der Seite erscheint dann:

Das steht in der sources.list

Was ist denn da wieder schief gelaufen?
Version:
Description: Debian GNU/Linux 12 (bookworm)
12.12
Viele Grüße
Michael Mildner
IT Support
16 Stunden später hat sich irgendwas gefangen. Der Fehler taucht nicht mehr auf.
Möglicherweise haben Server nicht funktioniert?

Frank Reinprecht
Hallo Herr Mildner,
Ich kann diesen Fehler nicht wirklich auf ein Update von uns zurückführen. Es gab Ausfälle der Azure-Cloud von Microsoft, es könnte damit zusammen hängen, weil dann "packages.microsoft.com" nicht erreichbar war. Evt. wurde das Repo auch abgeschalten oder aktualisiert.
Die sources.list sieht normal und unproblematisch aus. Es gibt bestimmt eine Repo-Datei unter /etc/apt/sources.list.d von Microsoft. Bitte kontrollieren Sie diese einmal. Wenn Sie sie mit mv zu Microsoft.list.disabled umbenennen, sollte apt wieder ohne Fehler laufen. Dann müsste man schauen, was die Liste definiert und wieso es nicht funktioniert. Die Fehler aus Ihrem ersten Screenshot deuten auf Verfügbarkeit hin, die heute schon wieder gegeben sein könnte.
Ein Update von uns als Ursache würde ich hier konkret erstmal ausschließen. Lassen Sie mich wissen, ob ein Fix der Microsoft-Repo-Datei Ihr Problem gelöst hat.
Mit freundlichen Grüßen,
Frank Reinprecht
Frank Reinprecht
Da haben sich unsere Kommentare überschnitten. Sehr gut, dann lag es wohl an dem Azure-Ausfall.
IT Support
Hallo Herr Reinprecht,
vielen Dank für die schnelle Rückmeldung.
Es lag wohl tatsächlich an der Azure Störung und stimmt zeitlich mit dem gemeldeten Ausfall https://azure.status.microsoft/de-de/status/history/ überein.
Es läuft wieder alles einwandfrei. Wir hatten uns zuerst nur über das Microsoft Repo für Linux und den darin enthaltenen Pfadangaben gewundert!
Ihnen ein schönes Wochenende
Viele Grüße
Michael Mildner